Concatenar fecha y hora en excel

Si tienes dos columnas en Excel, una con la fecha y la otra la hora. Para concatenar las en una sola celda principalmente existen dos formas.

Combinar fecha y hora en una sola celda de Excel sumando

Sumando las dos celdas, es seguramente la forma más fácil de conseguir una fecha combinada en una celda.

Concatenar fecha y hora en excel
=B3+C3

En este caso, solo te debes preocupar mediante el uso de formato de la celda mostrar el que quieras.

combinar fecha y hora en excel

Unir fecha y hora en excel con la función TEXTO

La otra forma de unir una fecha y hora en excel es usando la fórmula TEXTO. Este método es más largo que el anterior, pero te permite indicar el formato a mostrar.

Veamos como hacerlo.

Concatenar fecha y hora en excel facil
=TEXTO(B3;"dd/mm/aaaa ") & TEXTO(C3;"hh:mm:ss")

En el ejemplo anterior, vemos que con & podemos concatenar dos expresiones. Y usando la función TEXTO podemos indicarle el formato de la fecha y hora a mostrar.

También se puede usar la función CONCATENAR en vez de &. Veamos como:

=CONCATENAR(TEXTO(B3;"dd/mm/aaaa");" ";TEXTO(C3;"hh:mm:ss"))
  • dd Dia de la fecha con dos dígitos. En caso de ser un día inferior a 10, se mostrará con un 0 delante.
  • mm Los meses se muestran con dos dígitos.
  • aaaa El año se muestra con 4 dígitos. Aquí se puede optar por usar aa, para mostrar los dos últimos dígitos del año.
  • hh La hora en dos dígitos.
  • mm Los minutos en dos dígitos.
  • ss Los segudos en dos dígitos.

Otros formatos para mostrar las fechas:

  • mmm Muestra los meses en formato corto Ene, Feb, etc.
  • mmmm Muestra los mese con la descripción entera: Enero, Febrero, etc.
  • ddd Muestra el día de la semana: Mié, Jue, etc
  • dddd Muestra el día de la semana completo: Miércoles, Jueves, etc

¿Qué pasa si unes una celda con texto y otra con números que ya tienen formato?

Si intentas combinar una celda con texto y otra con números donde tienen formato, nos dará como resultado un número que a primera vista no tienen sentido.

como Concatenar fecha y hora en excel

¿Cómo usar el formato personalizado en fecha hora excel?

En algunos casos quieres mostrar el resultado de una fecha y hora en la misma celda en un formato en particular. Para ello puedes hacerlo de la siguiente forma:

Concatenar fecha y hora en excel avanzado

Vemos que la fecha hora queda con el formato que le indicamos.

Concatenar fecha y hora en excel como

Otra utilidad muy práctica puede ser sustituir la barra / por el guion , quedando así:

Concatenar fecha y hora en excel personalizada