Función BUSCARV Excel

BUSCARV (en inglés VLOOKUP) de Excel es una de las funciones más usadas y útiles, pero que genera más problemas de comprensión. En este artículo te la explicamos de forma fácil.

¿QUÉ ES BUSCARV?

Esta función te permite relacionar tablas de datos, de forma que pues hacer una búsqueda de un valor concreto dentro de una tabla o matriz, y una vez encontrado te devuelve los elementos asociados.

En este caso la búsqueda la realiza en la primera columna en vertical, de la matriz seleccionada.

SINTAXIS DE LA FUNCIÓN BUSCARV EXCEL

Conocer la sintaxis de la fórmula es esencial para usarla correctamente. La puedes aplicar directamente en una celda de Excel de la siguiente forma:

=BUSCARV(valor_buscado;matriz_buscar_en;indicador_columnas;[ordenado])

O por el contrario lo puedes hacer con la interficie gráfica:

Función BUSCARV Excel

En los dos casos, los argumentos que necesita BUSCARV son:

  • Valor_buscado (obligatorio): Es el valor que queremos buscar. Este valor será buscado, de arriba hacia abajo, en la primera columna de la matriz de búsqueda. Se puede hacer referencia a una celda que tenga el valor buscado o indicar el valor directamente entre comillas.
  • Matriz_buscar_en (obligatorio): Es el rango de datos donde se realizará la búsqueda. BUSCARV siempre buscará el valor en la primera columna y el resto de columnas sus valores podrán ser devueltos como resultado.
  • Indicador_columnas (obligatorio): Es un valor numérico que nos indica el número de columna que queremos devolver su valor. La primera columna tiene el valor 1.
  • Ordenado (opcional): Es un valor lógico. Si indicamos FALSO buscará una coincidencia y si es VERDADERO será aproximada (en este caso los datos deben estar ordenados). Si omitimos este dato el valor por defecto es FALSO.

EJEMPLO PRÁCTICO DE BUSCARV

Imaginemos que tenemos todos nuestros artículos de venta codificados. Y que a partir del código de artículo queremos saber el estoc que queda.

Función BUSCARV Excel como

La fórmula quedaría de la siguiente forma:

=BUSCARV(G1;A1:C11;3;FALSO)

Explicación de los argumentos introducidos:

  • G1 Es la referencia de la celda que contendrá el valor a buscar.
  • A1:C11 Es el rango de trabajo, donde la primera columna siempre tendrá los valores a buscar y las siguientes son valores que se pueden devolver.
  • 3 Es el número de columna de la que se devolverá el valor.
  • FALSO Indicamos que queremos una coincidencia exacta.

Así, si buscamos el código de artículo CM04 nos devuelve su estoc actual que es 14.

Función BUSCARV Excel ejemplo

<Descarga del ejemplo>

Aprovechando el ejemplo, vemos que el valor buscado está en nuestro rango. ¿Qué hubiera pasado si no estuviese? Pues que al no encontrar el valor nos devolvería un #N/D que nos indica que no lo encuentra.

Función BUSCARV Excel #N/D

En caso de no querer que aparezca #N/D, muchos usuarios de Excel prefieren indicarle un mensaje.

Vamos a mejorar nuestro ejemplo con un mensaje más claro.

=SI.ERROR(BUSCARV(G1;A1:C11;3;FALSO);"VALOR NO ENCONTRADO")

Añadimos la función SI.ERROR que en caso de que nos dé un error muestra el mensaje que definamos. Por lo contrario si no hay error devuelve su valor.

Función BUSCARV Excel uso

BUSCARV un valor numérico

En vez de hacer referencia a una columna, se puede realizar búsquedas de valores numéricos directamente.

Veamos la sintaxis:

=BUSCARV(10, A1:E10; 3; FALSO)

BUSCARV unA CADENA DE TEXTO

De la misma forma que el ejemplo anterior, en vez de hacer referencia a una columna, se puede realizar búsquedas de cadenas de texto directamente.

Veamos la sintaxis:

=BUSCARV(“Manzana”, A1:F10; 2; FALSO)

PREPARACIÓN DE LOS DATOS

Antes de aplicar un BUSCARV debemos tener en cuenta la preparación de los datos en la matriz y que cumplan varias reglas:

  • Los datos deben tener un formato tabular tipo tabla, con filas y columnas. No hay problema que haya un encabezado.
  • Siempre la columna que tiene los datos a buscar debe ser la primera y estar a la izquierda de todas.
  • En caso de usar búsquedas aproximadas los datos de la primera columna deben estar ordenados.

CÓMO COPIAR UNA FÓRMULA DE BÚSQUEDA

Al trabajar con BUSCARV puede ser muy habitual tener la necesidad de copiar la fórmula en celdas adyacentes.

Para ello, hay que prestar atención a las referencias usadas dentro de la fórmula para evitar errores en resultados.

A continuación a partir de nuestro ejemplo con unos retoques podremos ver de qué forma se puede copiar la fórmula sin fustrarnos.

Si modificamos nuestro ejemplo para que muestre los resultado en una tabla y arrastramos la fórmula BUSCARV veremos que no se copia correctamente.

Función BUSCARV Excel practicar
=SI.ERROR(BUSCARV(F4;A3:C13;3;FALSO);"VALOR NO ENCONTRADO")

Podemos observar que la fórmula en la celda G4 el rango no es correcto. Para evitar que ocurra esto, se debe usar $ delante del rango de forma que le indicamos que es fijo. Al final el $ lo que está haciendo es usar referencias absolutas en vez de relativas.

=SI.ERROR(BUSCARV(F4;$A$1:$C$11;3;FALSO);"VALOR NO ENCONTRADO")

Si observamos la fórmula anterior, el valor buscado no tiene $ porque sí que nos interesa que se aplique la referencia relativa.

Aspectos que debemos tener en cuenta de la función BUSCARV

  • La función BUSCARV siempre buscar los valores de forma vertical.
  • El valor buscado siempre debe estar en la primera columna del rango indicado.
  • El número de columna contiene la información requerida a partir del elemento buscado.
  • FALSO indica que la búsqueda es exacta. Si no encuentra una coincidencia devuelve #N/D o #N/A dependiendo de la versión de Excel.
  • Si se realiza una búsqueda aproximada con VERDADERO, los valores a buscar deben estar ordenados.